SYMPTOM:
When using Object manager to migrate the objects between the projects in Strategy 9.x, users get the following error message.

Object with ID XXXXXX and type 29 (DB Instance) is not found in metadata. It may have been deleted.
CAUSE:
This issue occurs because there is an inconsistency in the metadata. There are references to the deleted or changed DB instances that still exist in metadata. In order to track down the cause of this inconsistency, customers encountering this issue should make note of Schema/Application-related changes, Object Migrations or error messages prior to experiencing the problem. Change Journaling, if enabled, can help in preserving this information.
ACTION:
If the deleted DB instance is present in any other metadata or the backup of the current metadata (search for the object by ID coming in the error message), then migrating that DB Instance in the destination project first may resolve this issue. If the deleted DB Instance does not exist at all, then contact Strategy Technical Support to resolve the inconsistency.