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KB36857: "Error in login. Invalid Login Mode." error occurs immediately after login to MicroStrategy Web in a load balanced environment employing a "round robin" load balancing scheme


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SYMPTOM:
In an environment with clustered web servers using a "round robin" load balancer, the following error is received immediately after logging into Strategy Web:
 
 

ka04W00000147veQAA_0EM4400000027bo.png

 


Error in login.

Invalid Login Mode.

 
 
 
CAUSE:
"Round robin" web server clustering is not created through Strategy, but instead is created through third-party software. As such, web based sessions are not shared or persisted between more than one Strategy Web 9.x server. After a user logs into this cluster environment, the session is only authenticated and created on a single Strategy Web server. When the "round robin" load balancer sends subsequent requests to another server, there is no established authenticated session on it. Thus the above error message is generated as a result.
 
 
ACTION:
Sticky Bits should be implemented on the load balancer and web servers to prevent user sessions from switching between the multiple web servers. Sticky Bits bind a user session to one specific web server. Instead of rotating load balance on a "round robin" basis, sticky bits simply attempts to  balance the load by sending new users to the web server with the least user sessions.
 
 


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Knowledge Article

Published:

June 7, 2017

Last Updated:

August 7, 2020