SYMPTOM:
After executing a report from Strategy Web and selecting the 'Subscribe to Email' option, users may encounter the following message:

Sample Code/Error
You have no email address defined. Define an email address before creating a subscription or contact administrator.
This prevents users from proceeding to create new Distribution Services to be sent via email.
However, in the User Editor in Developer, the users in question do have email addresses defined:

CAUSE:
One possible cause of this behavior may be that the 'Denied All' permission has been implemented for the 'Everyone' group on the email device:

ACTION:
This issue can be rectified by amending the security level for the 'Everyone' group on the email device to 'View'.