EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB37426: Users receive a message when attempting to create an e-mail subscription in Web: "You have no email address defined. Define an email address before creating a subscription or contact administrator"


Community Admin

Placeholder •


When creating an e-mail subscription, users receive the following message: "You have no email address defined. Define an email address before creating a subscription or contact administrator".

SYMPTOM:
 
After executing a report from Strategy Web and selecting the 'Subscribe to Email' option, users may encounter the following message:

ka0PW00000019sTYAQ_0EM440000002NCn.png

 
Sample Code/Error
You have no email address defined. Define an email address before creating a subscription or contact administrator.
 
This prevents users from proceeding to create new Distribution Services to be sent via email.
 
However, in the User Editor in Developer, the users in question do have email addresses defined:
 

ka0PW00000019sTYAQ_0EM440000002NCs.png

 
 
CAUSE:
 
One possible cause of this behavior may be that the 'Denied All' permission has been implemented for the 'Everyone' group on the email device:

ka0PW00000019sTYAQ_0EM440000002NCx.png

 
ACTION:
 
This issue can be rectified by amending the security level for the 'Everyone' group on the email device to 'View'.
 
 


Comment

0 comments

Details

Knowledge Article

Published:

May 30, 2017

Last Updated:

March 7, 2024