EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB37823: "Data loading has failed! There is no project to transfer; this could be because all the projects are unloaded, idle or deleted" error message appears when performing an Enterprise Manager data load in MicroStrategy 9.x


Community Admin

• Strategy


"Data loading has failed! There is no project to transfer; this could be because all the projects are unloaded, idle or deleted" error message appears when performing an Enterprise Manager data load in MicroStrategy 9.x

SYMPTOM:
When performing an Enterprise Manager data load in Strategy 9.x, the process will fail with the error "Data loading has failed! There is no project to transfer; this could be because all the projects are unloaded, idle or deleted". Additionally, the following messages will be logged in the MSTRMigration.log file:
 
Sample Code/Error
   No server is available to connect to <PROJECT NAME>
   WARNING: Cannot load data from Project <PROJECT NAME>. This could be because the Project is unloaded, idle or was deleted.
 
Lastly, the connection to the Intelligence Server on Desktop works fine and shows all the projects are loaded.
 
CAUSE:
The issue is caused because Strategy Enterprise Manager is unable to connect to the Intelligence Server.  It's important to note that Enterprise Manager does not use the name exactly as entered when creating a project source. Instead it queries the DNS Server for the name of the machine and stores that in the EM_PROPS table under the EM_PROP_NAME column listed as "CLUSTER MEMBER". If the value stored here is not resolveable Enterprise Manager dataload will fail.
 
ACTION:
There are 2 solutions to this problem:
 
1. Modify the HOSTS file of the Enterprise Manager machine so that the name stored in the table correctly resolves. This can be accomplished by referring to the following Strategy Knowledge Base technical note:
KB36645: "There is no project to transfer" and "Cannot load data from Project . This could be because the Project is unloaded, idle or was deleted" errors occur when attempting to perform a data load in Strategy Enterprise Manager 8.1.x - 9.x 
2. Modify the value stored in the EM_PROPS Table under the "EM_PROP_VALUE" that correlates to the "Cluster Member" EM_PROP_NAME so that it refers to a resolvable Intelligence Server.
 


Comment

0 comments

Details

Knowledge Article

Published:

June 5, 2017

Last Updated:

June 5, 2017