EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB38677: Error when executing report in MicroStrategy Web 9.4.1 in an environment with clustered Intelligence Servers: 'MsiUserInbox: Failed to persist the results of this message'


Community Admin

• Strategy


Describes scenario in which proper permissions were not set on a centralized location for History List inbox sharing, causing errors to return.

SYMPTOM:
When trying to execute reports in Strategy Web 9.4.1 users receive the following error:
 

ka04W000000OcauQAC_0EM4400000029wX.jpeg

 


User request is queued.
MsiUserInbox: Failed to persist the results of this message. Please check that the cache configuration is proper and that the history list directory as specifid in the server definition exists on the Intelligence Server machine.
System Error (EaCCES): --- Permission denied
MsiUserInbox: Failed to persist the results of this message. Please check that the cache configuration is proper and that the history list directory as specifid in the server definition exists on the Intelligence Server machine.

 
This error occurs in a clustered environment, configured to use a central shared location for Inbox sharing.
 
CAUSE:
This issue occurs because the Intelligence Server user on one or more of the nodes does not have the correct permissions to access the shared inbox directory.
 
ACTION:
To resolve this issue, make sure that the Intelligence Server user on all nodes has the appropriate permissions to write to the shared inbox directory.


Comment

0 comments

Details

Knowledge Article

Published:

May 9, 2017

Last Updated:

May 9, 2017