SYMPTOM:
When trying to load a cube on clustered node in Strategy Developer 9.4.x - 10.x the following error occurs:
Cube instance XXXX cannot be loaded into memory due to error -2147072546. Cube command failed with error -2147072540

CAUSE:
One possible cause of this error message is that the Cube cache file has not be written to memory yet. This can be confirmed by looking at the Intelligent cube cache file on the node that the cube was created on. If it is not written to file it will look like the below screen shot:
ACTION:
Decrease the Backup Frequency = '0' so that when a cube cache is created, it is immediately written to disk. This will allow other nodes to load it into memory.
To configure this setting, go to:
Configure Intelligence Server>Server Definition> Advanced. The Intelligence Servers must be restarted for the settings change to take affect.

A detailed explanation of cube publishing can be found in:KB31566: MicroStrategy 9.x Intelligent Cube status indication and workflow