After changing the login password to the machine running Strategy Health Center on it, an error might occur as shown in the image below.

Could not connect to Machine:44440 - Could not connect to Machine:44440 - IOException connection to Machine: Connection refused: no further information - Failed to connect to Machine:44440.

Sample Code/Error
The configuration of your Master Health Agent encountered errors. Please reconfigure it.
-The configuration of your Master Health Agent encountered errors. Please Reconfigure it.
CAUSE:
The MSTRExec.exe service is running as the user that the password was changed for.
ACTION:
Reconfigure Strategy Master Health Agent Service and update the password as shown in the image below.
