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KB439516: "LOGIN_MUST_USE_SECURITY_TOKEN: Invalid username, password, security token; or user locked out." error appears when attempting to execute XQuery report against Salesforce data source in MicroStrategy Developer 10.x


Tianfeng (Jimmy) Jiang

Quality Engineer, Principal • MicroStrategy


This article shows issue that "LOGIN_MUST_USE_SECURITY_TOKEN: Invalid username, password, security token; or user locked out." error appears when attempting to execute XQuery report against Salesforce data source in MicroStrategy Developer 10.x. This is because security token for Salesforce login is not appended to password. Append security token to password as new password to resolve the issue.

SYMPTOM:
"LOGIN_MUST_USE_SECURITY_TOKEN: Invalid username, password, security token; or user locked out." error appears when attempting to execute XQuery report against Salesforce data source in Strategy Developer 10.x as shown below:

ka02R000000kV3uQAE_0EM44000000QGMH.png

 


Error: SQL Generation Complete
QueryEngine encountered error: axis2_svc_client_send_receive failed. Web Service returned a soap fault. 
Error type: XQuery Engine error. <soapenv:Fault><faultcode>sf:LOGIN_MUST_USE_SECURITY_TOKEN</faultcode><faultstring>LOGIN_MUST_USE_SECURITY_TOKEN: Invalid username, password, security token; or user locked out. Are you at a new location? When accessing Salesforce--either via a desktop client or the API--from outside of your company’s trusted networks, you must add a security token to your password to log in. To get your new security token, log in to Salesforce. From your personal settings, enter Reset My Security Token in the Quick Find box, then select Reset My Security Token.</faultstring><detail><sf:LoginFault xsi:type="sf:LoginFault"><sf:exceptionCode>LOGIN_MUST_USE_SECURITY_TOKEN</sf:exceptionCode><sf:exceptionMessage>Invalid username, password, security token; or user locked out. Are you at a new location? When accessing Salesforce--either via a desktop client or the API--from outside of your company’s trusted networks, you must add a security token to your password to log in. To get your new security token, log in to Salesforce. From your personal settings, enter Reset My Security Token in the Quick Find box, then select Reset My Security Token.</sf:exceptionMessage></sf:LoginFault></detail></soapenv:Fault>. Connection String: XQUERY;UID=Data;.. 
Error in Process method of Component: QueryEngineServer, Project Strategy Tutorial, Job 254, Error Code= -2147212544.

CAUSE:
When accessing Salesforce via SOAP API, a security token must be appended with the password to log in. 
ACTION:
1. Follow article below to reset security token:
https://success.salesforce.com/answers?id=90630000000glADAAY
Then, security token should be received via email.
2. Append security token to password as the new password for login.
For example, if the password for Salesforce login is 123456 and the token received is kdjhtkwbduebd, the new password is 123456kdjhtkwbduebd.
  KB439516


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Knowledge Article

Published:

January 22, 2018

Last Updated:

December 6, 2018