SYMPTOM:
The following error message appears when applying Report Filter or View Filter with an attribute ID containing tilde character "~" in Strategy Web 9.x:
Error in report results
Your request could not be processed due to a server error.
Please try again. If the problem persists, contact the server Administrator.
You have included an invalid argument.
STEPS TO REPRODUCE:
The following steps were taken to reproduce the issue in Strategy Tutorial:
- In Strategy Desktop, locate the attribute Category, and edit it, modify "Category ID" Format type from Number to Nvarchar.
- Go to Strategy installation folder (by default, it is under C:\Program Files\Strategy\Tutorial Reporting), open Tutorial project warehouse database TUTORIAL_DATA_7200.mdb, add a new row to the table LU_CATEGORY. Add the character "~" in CATEGORY_ID column and add "test" in CATEGORY_DESC column. Save the changes.
- Update schema.
- In Strategy Web, create a new report with the attribute Category in the row.
- Add Category in the Report filter-> Select -> Add " ~:test " list box.
- Click Apply button, note that the error message appears.
CAUSE:
This is a known issue with Strategy Web 9.x.
ACTION:
Contact Strategy Technical Support for an update of this issue.