EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB41396: “You have included an invalid argument” error message appears when applying Report Filter or View Filter with an attribute ID containing tilde character "~" in MicroStrategy Web


Community Admin

• Strategy


The following error message appears when applying Report Filter or View Filter with an attribute ID containing tilde character "~" in MicroStrategy Web:

SYMPTOM:
 
The following error message appears when applying Report Filter or View Filter with an attribute ID containing tilde character "~" in Strategy Web 9.x:
 
 


Error in report results

Your request could not be processed due to a server error.
Please try again. If the problem persists, contact the server Administrator.
You have included an invalid argument.

 
 
 
STEPS TO REPRODUCE:
 
The following steps were taken to reproduce the issue in Strategy Tutorial:
 

  1. In Strategy Desktop, locate the attribute Category, and edit it, modify "Category ID" Format type from Number to Nvarchar.
  2. Go to Strategy installation folder (by default, it is under C:\Program Files\Strategy\Tutorial Reporting), open Tutorial project warehouse database TUTORIAL_DATA_7200.mdb, add a new row to the table LU_CATEGORY. Add the character "~" in CATEGORY_ID column and add "test" in CATEGORY_DESC column. Save the changes.
  3. Update schema.
  4. In Strategy Web, create a new report with the attribute Category in the row.
  5. Add Category in the Report filter-> Select -> Add " ~:test " list box.
  6. Click Apply button, note that the error message appears.

CAUSE:
 
This is a known issue with Strategy Web 9.x.
 
 
ACTION:
 
Contact Strategy Technical Support for an update of this issue.
 
 
 
 


Comment

0 comments

Details

Knowledge Article

Published:

June 21, 2017

Last Updated:

June 21, 2017