SYMPTOM:
Images on dashboard fail to load due to incorrect URL being triggered. The incorrect URL is formed using HTTP when HTTPS should be used. (see image below, images are retrieved using HTTP protocol and other requests are using HTTPS protocol)

CAUSE:
Cause is unknown. Potentially it's related to the environment network setup; however, this issue can be resolved using the following workaround below.
WORKAROUND:
Add the configServletPath parameter in global section of the Strategy.xml file under WEB-INF as following:
<application> <global> <parameter name="configServletPath" value="https://<webServer>:port/MSTRWeb/"/>