SYMPTOM:
When an Intelligent Cube is manually refreshed in Strategy Developer 9.x, there is no issue and the information in the cube is updated as desired. However, when trying to refresh the cube using a scheduled subscription, the cube is not updated with the latest information.
CAUSE:
One reason for this issue is that there exists a product limitation when executing scheduled subscriptions in addition to Kerberos Authentication. If Kerberos is being used, this will prevent scheduled subscriptions from running successfully.
ACTION:
Since this is a product limitation regarding the combination of Kerberos Authentication and scheduled subscriptions, there is no way to use the two in conjunction. However, as described below, there are a few workarounds to this issue.
WORKAROUND:
Workaround 1:
Refresh Intelligent Cubes manually.
Workaround 2:
Create a non-Kerberos authenticated database login. This must be done by the DBA and Strategy Technical Support will not assist with this. Connection mapping can then be used to map the desired Strategy users to this database login. Any user who creates scheduled subscriptions will need to be mapped to this database login, since it does not user Kerberos Authentication.
Workaround 3:
Alternatively, an entirely new database instance can be created without usinhg Kerberos Authentication. Ensure that the Project Configuration Kerberos setting is turned off for this database instance. Any scheduled subscriptions running through this database instance will work since Kerberos Authentication is not being used.
KB42179