SYMPTOM:
There are repeated entries of the same error message in Web Log though users do not report any issue.
Sample Code/Error
java.net.UnknownHostException: {iserver}
at java.net.InetAddress.getAllByName0(Unknown Source)
at java.net.InetAddress.getAllByName(Unknown Source)
at java.net.InetAddress.getAllByName(Unknown Source)
at java.net.InetAddress.getByName(Unknown Source)
at com.Strategy.webapi.CDSSXMLAdmin.GetHostAddr(Unknown Source)
at com.Strategy.webapi.CDSSXMLAdmin.FindClusterNode(Unknown Source)
at com.Strategy.webapi.CDSSXMLAdmin.GetCluster(Unknown Source)
at com.Strategy.web.objects.WebClusterAdminImpl.getCluster(Unknown Source)
at com.Strategy.web.objects.WebIServerSessionListImpl.findSessionsByServer(Unknown Source)
at com.Strategy.web.objects.WebIServerSessionListImpl.getByServerProject(Unknown Source)
at com.Strategy.web.app.beans.WebAppSessionManagerImpl.getSession(Unknown Source)
at com.Strategy.web.app.beans.WebAppSessionManagerImpl.initActiveSessionFromRequest(Unknown Source)
at com.Strategy.web.controller.GenericWebAppController.setupSessionManager(Unknown Source)
at com.Strategy.web.controller.GenericWebAppController.processRequest(Unknown Source)
CAUSE:
One of the potential causes of this error is discussed in technote:
KB14215: User receives error "There are no projects connected to this web server. To configure projects, go to the Web Administrator" in MicroStrategy Web 9.x and later.
But even when there is no issue with the connection between Web Server and Intelligence Server, this error could be found if the user tries running a report or a document with a URL API where the name of the Intelligence Server is incorrect or is not able to be resolved by DNS server.
ACTION:
If there is a customization present, test without the customization to see if the errors go away, which would confirm that there is a reference in one of the customization plug-ins to the Intelligence Server name. Also check if there is any URL API with incorrect Intelligence Server name, and correct it.