SYMPTOM:
When a new attribute is added to a hierarchy, the attribute by default will not show up in the Strategy Developer Data Explorer side bar. This is the area found when navigating to Schema Objects - Hierarchies - Data Explorer folder and navigating the various created hierarchies.
CAUSE:
By default the attribute will be added to the hierarchy and will not be set as an Entry Point. This means it cannot be navigated to when exploring in the Data Explorer window.
ACTION:
In the Graphical Architect, change tab to Hierarchy View, find the attribute in question, and change it to "Set as an Entry Point". This will display it when in the Data Explorer window.