EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB43874: MicroStrategy Integrity Manager 9.x and newer Data comparison test fails even though users are connected to the same database for all comparison projects and the SQL generated didn't change.


Community Admin

• Strategy


This KB discusses an issue seen when comparing reports from two projects in Integrity Manager.

SYMPTOM:
In Strategy Integrity Manager 9.x and newer, when comparing reports from two projects the "Data" comparison test fails even though the two projects are pointing to the same database and the SQL generated remained the same. When reviewing the output of the test (e.g., CSV data file output) it can be confirmed that the data appears to be exactly the same for the two reports.
 
CAUSE:
This can happen if the "white spaces" in the attribute elements names are being automatically trimmed for one of the projects. This can happen when each project setting has a different way to display the data in Strategy Web.
 
ACTION:
This setting can be modified in Strategy Web for each project:
Strategy Web > Project Defaults > Preferences > General > Data display > "Trim leading and trailing white space for warehouse element data" setting.

ka04W000000Ohb6QAC_0EM440000002HLE.jpeg

 
Once the option has been enable/disabled for the two projects, the test should not fail in Strategy Integrity Manager.
 
The Strategy Internal Reference Number for the issue discussed in this KB is 464933.


Comment

0 comments

Details

Knowledge Article

Published:

May 10, 2017

Last Updated:

May 10, 2017