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KB439275: "Database error" Occurs When Attempting to Connect to Salesforce Using MicroStrategy ODBC Driver on MicroStrategy 10.3


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"Database error" Occurs When Attempting to Connect to Salesforce Using MicroStrategy ODBC Driver on MicroStrategy 10.3

SYMPTOM:
Users attempts to connect to Salesforce using MiroStrategy ODBC driver on Strategy 10.3 and the following error message is obtained:


Database error <5>: Connect failed. %0d%0aError type: Odbc error. Odbc operation attempted: SQLDriverConnect. [08004:10023: on SQLHANDLE] [Strategy][ODBC Salesforce driver] [Salesforce]com.ddtek.sforce.externals.org.apache.cxf.interceptor.Fault: Unmarshalling Error: unexpected element (uri:"urn:fault.partner.soap.sforce.com", local:"upgradeURL"). Expected elements are <{urn:fault.partner.soap.sforce.com}exceptionCode>,<{urn:fault.partner.soap.sforce.com}exceptionMessage>

CAUSE:
This is caused by the Salesforce ODBC driver with version of 7.10.4.136, which is installed with Strategy 10.3 by default.
 
ACTION:
Upgrade to Salesforce ODBC Driver version 07.16.0210 (B0307, U0205) or higher.
Salesforce ODBC driver with version of 7.10.4.136 is no longer used in Strategy 10.4 or later version by default, so update to Strategy 10.4 or later version can also help to address this issue.
 


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Knowledge Article

Published:

December 21, 2017

Last Updated:

December 21, 2017