EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB439358: Error message 'Please enter valid timestamp in the format : 'MM/dd/yyyy hh:mm:ss a'' appears when running a script in Command Manager 10.4


Yefang Zhou

Manager, Cloud Support • MicroStrategy


When Region Format is set to be Japanese in the Client machine with Command Manager 10.4 installed, running a script contains a timestamp, error message 'Please enter valid timestamp in the format : 'MM/dd/yyyy hh:mm:ss a'' appears

SYMPTOM:
When Region Format is set to be Japanese in the Client machine with Command Manager 10.4 installed, running a script contains a timestamp, error message as below appears.

ka04W000001Iv3kQAC_0EM44000000QD6G.png


Please enter valid timestamp in the format: 'MM/dd/yyyy hh:mm:ss a'.

 
CAUSE:
The root cause is that Command Manager 10.4 initialize the timestamp without a specific locale. When the system date format is set to be Japanese, it can't parse a string like '11/30/2012 11:22:23 AM', instead it can only parse an String as '11/30/2012 11:22:23 午前'. 
 
ACTION:
This issue has been fixed in Command Manager 10.4.6 and 10.10. Upgrade to this version to take the advantage of this fix.


Comment

0 comments

Details

Knowledge Article

Published:

January 22, 2018

Last Updated:

January 22, 2018