SYMPTOM:
In Strategy Web 10.4, when running a Visual Insight Dashboard using Live Connect with custom group in the filter panel and unselecting one custom group filter item, users see ‘Loading Data …’ when there is a big volume of data and the report may not come back in a timely manner.

CAUSE:
This is a known defect in Strategy Web 10.4 using Live Connect in Visual Insight. This is caused due to Strategy querying all columns from all tables when adjusting the filtering for custom group elements.
ACTION:
This issue has been fixed in Strategy 10.9. Now, only the required columns and tables are queried when changing the filtering for custom groups in a Visual Insight Dashboard.
Strategy reference numbers for this technical note are KB439635 and DE53646. KB439635