SYMPTOM:
In Strategy Mobile 9.4.x-10.x, a feature is available to 'Select All' elements or 'Clear All' elements from a filter-prompt pane when executing a report that contains attribute element prompts, like shown below:


However, users may observe that in some cases, these options are not available, like shown below:

CAUSE:
In order to qualify for the 'Select All' option to show without affecting the performance of the application, two conditions have to be met:
In order to qualify for the Clear All option to show, the number of elements in the attribute being prompted must be greater than or equal to 10.
ACTION:
Ensure that the attribute in question meets the requirements mentioned above. If the prompt contains over 100 elements, a filter to narrow down the prompt options should be enforced.