EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB441459: Exporting a document results in a repaired part error when opening in Excel


Community Admin

• Strategy


Exporting a paged document results in a repaired part error when opening in Excel.

 

Summary

When exporting a multi page prompted document to excel, an error may occur. The error states:
 


<?xml version="1.0" encoding="UTF-8" standalone="yes"?> 
<recoveryLog xmlns="http://schemas.openxmlformats.org/spreadsheetml/2006/main"><logFileName>error025280_01.xml</logFileName><summary>Errors were detected in file 'file in drive location'</summary><repairedParts><repairedPart>Repaired Part: /xl/worksheets/worksheet2.xml part with XML error. Load error. Line 1, column 0.</repairedPart></repairedParts></recoveryLog>

This is a known issue that can be resolved by changing the export memory settings.

Steps to reproduce:

  1. Open any multi page prompted document in Strategy Web.
  2. Export to an Excel sheet by clicking the menu button in the top right, selecting export, and selecting Excel.
  3. A popup message will appear asking if you want to export the current page or all pages. Select export all pages.
  4. The document will export into a .xml file in your set export location.
  5. Open the file using Microsoft Excel
  6. An error message appears stating
ka04W00000148vaQAA_0EM44000000WfvL.png

 


We found a problem with some content in "Document Name.xmlx". Do you want us to try to recover as much as we can? If you trust the source of this workbook, click Yes.

  1. Click yes
  2. The first tab of the Excel workbook is labeled "Warning Message". A Repairs pop-up menu appears. Click the link on the pop-up to view the log file listing repairs. Log shows the repaired page error.
ka04W00000148vaQAA_0EM44000000WfvQ.png

CAUSE:

The Strategy Export Engine cannot generate a complete result due to a set memory limitation. The current governing limit for  file generation is not enough to fully export the document. This causes the warning message to display stating that only part of the result is exported. Since only part of the result is exported, some data is missing which leads to the file not opening.
 

ACTION:

The user should increase the Excel Generation governing limit to "-1,"  unlimited, and export the document again. As long as the server's total memory limit is not reached the export should be successful. 
To change the Governing Limit:

  • In Strategy Developer right click on the Project Source and select Configure Strategy Intelligence Server
  • Under Governing Rules on the left, select File Generation.
  • In this menu change the value listed for "Maximum memory consumption for Excel file" to "-1".

ka04W00000148vaQAA_0EM44000000WfvG.png

This should allow the Excel file generation to consume as much memory as required to successfully export. Please be aware that this will not be successful if the generation requires more memory than is available on your machine. 
 
 


Comment

0 comments

Details

Knowledge Article

Published:

August 7, 2018

Last Updated:

November 18, 2019