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KB44172: “No peer certificate” error message received in MicroStrategy Mobile App for Android 9.4.x when using HTTPS


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• Strategy


This KB article discusses an error that has been classified as expected behaviour. Steps to solve the error are provided

 
SYMPTOM:
In Strategy Mobile App for Android 9.4.x, the following error message is seen when using HTTPS:

ka04W000000OfbMQAS_0EM440000002UvW.jpeg

 


No peer certificate

 
 
CAUSE:
It is working as designed because Android doesn’t have an option to accept a certificate as trusted.  
 
ACTION:
Follow the steps below in order to inform Android that a certificate is trusted when using Strategy Mobile App for Android 9.4.x-10.x:
1) Insert the CA certificate file in a virtual directory that can be accessed by the mobile devices.
2) Copy the URL of the virtual directory containing the certificate file.
3) In the Mobile Configuration Page, click on the Add New Certificate option and add the referred URL in the Trusted Certificates box, as shown:

ka04W000000OfbMQAS_0EM440000002UvU.png

 4) Save and resend the configuration to all Mobile Devices
Please note that, this option is not available in 10.x. 
KB44172


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Knowledge Article

Published:

July 21, 2017

Last Updated:

August 3, 2018