Symptom:
When installing Hotfix 7 or Hotfix 8 on top of 10.4 in windows, even using administrator account, users receive the error message as below.
The following error occurred on the file :"C:\Program Files (x86)\Common Files\Strategy\XXXXXX.EXE" Access denied(0x5)"


It is actually a warning rather than an error because while click Retry or Ignore, users can continue the installation and complete successfully.
Cause:
This issue is caused by unclean machine.
Action:
To avoid this warning, uninstall the hotfix, repair the 10.4 installation and reinstall hotfix.
It is also strongly recommend to operate complete uninstall every time when users uninstall the product. For how to perform complete uninstallation, refer to the article below.
KB307710: How to uninstall MicroStrategy Analytics Enterprise using the Uninstallation Cleanup Utility
KB442627