SYMPTOM:
When trying to start the Intelligence Server through Windows Services, the service will not start. Additionally, the following error message is encountered:
Error 1069: The service did not start due to a logon failure

CAUSE:
This error happens when the password for the user account running the Strategy Intelligence Server service is changed but not updated in the service properties.
ACTION:
Update the password for the user account running the Strategy Intelligence Server service in the service properties (through Windows Services).