SYMPTOM:
After creating a new database instance pointing to an Oracle database and opening Warehouse Catalog with that database instance in Strategy Developer 9.4.x-10.x, users may encounter the following error:

No available tables were found in the warehouse catalog. This can happen due to three possible causes: a) All tables are already part of the project) b) An incorrect custom SQL statement is being used, or c) The warehouse connection is not defined correctly. Do you want to modify the Warehouse Catalog Browser options? Please re-run the Warehouse Catalog Browser after you make your changes.
ACTION:
Cause 1:
The first cause requires no troubleshooting, as this warning is automatically displayed after adding all tables to the project and reopening Warehouse Catalog.
Cause 2:
To troubleshoot the second cause, test the following.

Note: if the button is greyed out as shown above, the database instance selected uses ODBC calls to return tables and columns in Warehouse Catalog, so the warning is due to either the first or third cause.
In some instances, users report this issue when using the default table read SQL with their current database login. Below is the default table read SQL for Oracle databases:
SELECT DISTINCT OWNER NAME_SPACE, TABLE_NAME TAB_NAME FROM ALL_TABLES WHERE OWNER = '#LOGIN_NAME#' AND DROPPED = 'NO' UNION SELECT DISTINCT OWNER NAME_SPACE, VIEW_NAME TAB_NAME FROM ALL_VIEWS WHERE OWNER = '#LOGIN_NAME#
SELECT DISTINCT OWNER NAME_SPACE, TABLE_NAME TAB_NAME FROM ALL_TABLES WHERE DROPPED = 'NO' UNION SELECT DISTINCT OWNER NAME_SPACE, VIEW_NAME TAB_NAME FROM ALL_VIEWS