SYMPTOM:
Users receive multiple SQL0204 and SQL0206 errors after executing a Data Manipulation Language (DML) upgrade script on a Statistics repository or Enterprise Manager warehouse in Strategy 9.x.
Error type: Odbc error. Odbc operation attempted: SQLExecDirect. MSTRTSTSVC.IS_CUBE_REP_STATS_TMP IS AN UNDEFINED NAME. For more information, please consult DB2 document for error code SQL0204. DROP TABLE IS_CUBE_REP_STATS_TMP 0 0 00:00:00
Error type: Odbc error. Odbc operation attempted: SQLExecDirect. A.MESSAGEID NOT COLUMN OF INSERTED/UPDATED TABLE, OR ANY TABLE IN A FROM CLAUSE. For more information, please consult DB2 document for error code SQL0206. INSERT INTO IS_REPORT_STATS_TMP
CAUSE:The described errors are generated when the DML Script is executed against an Enterprise Manager or Statistics repository without first performing the necessary DDL upgrade. The purpose of the DML script is to populate new columns that are created in the DDL upgrade. The errors displayed above were generated when the DML script attempted to run a statement against a column that had not yet been created.
For more information regarding the DML upgrade of an Enterprise Manager or Statistics repository, refer to the following Strategy Knowledge Base Technical Notes:
KB39948 - Data Manipulation Language (DML) upgrade for statistics repository in Strategy 9.3.0 - 9.3.1
KB40014 - Data Manipulation Language (DML) upgrade for Enterprise Manager Warehouse in Strategy 9.3.0
ACTION:Users should NOT execute a DML script multiple times against an Enterprise Manager or Statistics repository. Users in this situation should restore a backup of their repository tables, perform the necessary DDL upgrade through via the Configuration Wizard or Enterprise Manager Console and then finally execute the proper DML script.