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KB46348: "com.microstrategy.utils.cache.CacheException: Connection timed out: connect" error message is shown when using ESRI maps in MicroStrategy Web


Community Admin

• Strategy


SYMPTOM:
After configuring and attempting to use ESRI maps, the following error message is seen:

ka04W00000148FbQAI_0EM4400000026H7.png

 
Error:
com.Strategy.utils.cache.CacheException: Connection timed out: connect
 
CAUSE:
The Web Server requires access to the internet to request a valid token from arcGIS. If the token cannot be requested, for example if no internet is available or the Web Server is behind a proxy, this request times out.
 
ACTION:
Proxy server support for HTTP requests to ESRI has been added in Strategy Analytics Enterprise 9.4.1 Hotfix 6. Customers are advised to upgrade to this version or later to take advantage of this.
Steps to configure proxy support can be found in the following Technical Note:
KB202342: Support using proxy server to send HTTP request to ESRI in MicroStrategy Analytics Enterprise 9.4.1 Hotfix 6
 
WORKAROUND:
Ensure that the Web Server has access to the internet without the use of a proxy, allowing it to connect to arcGIS servers.
 
 
 
KB46348


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Knowledge Article

Published:

March 30, 2017

Last Updated:

November 16, 2018