SYMPTOM:
During an upgrade of the metadata in Strategy 9.x, Configuration Wizard hangs after selecting the components to upgrade and clicking "Finish." The "Processing request..." window appears on the screen and remains there indefinitely. The upgrade never goes through, even after allowing several days for it to process.

CAUSE:
This issue has been known to occur when the installation of the new version of Strategy (i.e. the version that the metadata is being upgraded to) did not install correctly.
ACTION:
Performing a complete uninstall/reinstall of the Strategy Product Suite has been known to resolve this issue and allow the upgrade to successfully complete.