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KB46382: Pull down list selectors in Transaction Services documents always display the first element of a search result as the selection made by the user, regardless of which element was selected in MicroStrategy Analytics Enterprise 9.4.1


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• Strategy


Pull down list selectors in Transaction Services documents always display the first element of a search result as the selection made by the user, regardless of which element was selected in MicroStrategy Analytics Enterprise 9.4.1

SYMPTOM: 
A user searches for an attribute element using a pull down list selector in a Transaction Services Document. The pull down selector will show search results. However, regardless of what element is selected by the user, the pull down selector will always display the first element of the search result as the selection made by the user, in Strategy Analytics Enterprise 9.4.1.
 
The image below shows the selector returning all attribute elements for the Month attribute. At this point, no search has been made:

ka04W000000OaW2QAK_0EM4400000026Ew.png

 
The user then types in the letter "j" to perform a search. The following results appear:
 

ka04W000000OaW2QAK_0EM4400000026FB.png

 
The user then selects the third option, "Jul 2012", as shown below:
 

ka04W000000OaW2QAK_0EM4400000026F0.png

 
Instead of displaying "Jul 2012" as the selection made, the first element from the search results, "Jan 2012", is displayed in its place:
 

ka04W000000OaW2QAK_0EM4400000026F7.png

 
Note: For information on how to clear the search result refer to tech note KB46005 "A pull down list selector does not clear the search results after searching once in a transaction services document in Strategy Web 9.3.1 HF1"
 
STEPS TO REPRODUCE:
Follow these steps in a Strategy Tutorial Project:

  • Edit the Monthly Regional Sales Targets Planning document, located at:
    Shared Report/Strategy Platform Capabilities/Strategy Transaction Services
  • Create a panel stack and place 4 text boxes.
  • Right click on the text box and select Configure Transaction.
  • Search the transaction report called Update Revenue Targets.
  • Make the following configurations:
ka04W000000OaW2QAK_0EM4400000026F6.png
  • Run the document in Express mode, and follow the steps provided in the section above.

CAUSE:
 
This is a known issue in Strategy Web 9.4.1.
 
ACTION:
 
This issue has been fixed in Strategy Web 9.4.1 Hotfix 6. Take advantage of upgrading for a fix.
 
WORKAROUND:
If the list of elements is not too long, avoid using the search and manually select the element.
By manually selecting "Jun 2012", as shown below, the correct element is displayed.

ka04W000000OaW2QAK_0EM4400000026F9.png

 
And the pull down selector displays the correct selection, as shown below:

ka04W000000OaW2QAK_0EM4400000026FJ.png

 
 
 
KB46382


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Knowledge Article

Published:

June 12, 2017

Last Updated:

December 28, 2018