EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB47040: "Your request could not be processed. Please Try again. If the problem persists, contact the Administrator." error message appears when running an dashboard with multiple cubes in MicroStrategy Web


Community Admin

• Strategy


In MicroStrategy Web, when a user tries to run a dashboard containing multiple cubes, they may experience the following error message: "Your request could not be processed. Please Try again. If the problem persists, contact the Administrator."

SYMPTOM:
In Strategy Web 9.4.1 and above, when a user tries to run a dashboard containing multiple cubes, they may experience the following error message:


Your request could not be processed. Please Try again. If the problem persists, contact the Administrator.
(Internal Error: DSSDocumentExecuteTask::Run(): Error calling DocumentInstance::Execute ,job 1212, Error Code=-2147418113).

 
In the DSSErrors log, an entry similar to the following is seen:

The size of cross join result exceeds limit: MAXInt = 2147483647

 
 
CAUSE:
When a dashboard has multiple cube datasets, the Strategy engine performs compound joins across all the attributes. A compound join is simply an outer join on shared attributes, and a cross join on non-shared attributes between the datasets. The "size of cross join result exceeds limit" error occurs when this compound join results in a number of rows that surpasses the internal governing limits - in the above example, this limit was 2,147,483,647 rows. This usually occurs when the cubes within the document are each large individually, and thus when joined, become enormous.
 
WORKAROUND:
Resolution of this issue needs to be done on a case-by-case basis, but generally, reducing the size of the individual cubes and streamlining the cube design is the best approach to preventing this issue. If there are more than 2 cubes, removing one of them from the dashboard has also been known to resolve this issue.


Comment

0 comments

Details

Knowledge Article

Published:

April 3, 2017

Last Updated:

April 3, 2017