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KB47117: Exporting a document or report to Excel from Internet Explorer and choosing to "Open" it, prompts the users for network credentials in MicroStrategy Web 9.x and 10.x.


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In MicroStrategy Web 9.x, when a user exports a report or document to Excel using Internet Explorer and chooses the "Open" option, a window pops up prompting the user for credentials.

SYMPTOM:
In Strategy Web 9.x, when a user exports a report or document to Excel using Internet Explorer and chooses the "Open" option, a window pops up prompting the user for credentials, as shown below:
 
 
 
 
To properly diagnose this issue, open the Microsoft Task Manager, by pressing Ctrl+Shift+Esc, and find the Windows Security task, as shown below:
 
 
Right click on the Task and select "Go to process", as shown below:
 
 
The process listed should be "EXCEL.f", as shown below:
 
 
Additionally, when exporting the report or document and selecting "Open", when viewing the HTTP headers it is possible to see an "OPTIONS" header noting that it is a Microsoft Office product issuing the request, as seen below:
 
This issue does not occur when selecting "Save" or "Save as".
 
CAUSE:
This issue is caused by Microsoft Excel 2007 and newer in combination with Microsoft WebDAV being configured in Microsoft IIS and not by Strategy Web 9.4.1. When "Open" is selected, Microsoft Excel attempts to open the file directly from the web server temporary folders instead of downloading the file to the client PC and then running it from there.  When the temporary folders that Microsoft IIS uses do not have the appropriate ACL permissions, users will be prompted for credentials as Microsoft Excel is attempting to access a folder that it does not have permissions for.
ACTION:
Contact Microsoft Support for assistance on how to provide the appropriate permissions to the temporary folders that Microsoft IIS uses when serving Excel files. These folders could be in different locations depending on the version of Microsoft Windows, IIS, and how WebDAV was configured, thus finding these folders falls outside the scope of Strategy Technical Support. This issue is also covered in a Microsoft Knowledge Base article located here.
WORKAROUND:
Use "Save As" to download the file directly to the client machine before opening the export file to run it from the client machine rather than from the web server machine.
Third Party Software WARNING:
The third-party product(s) discussed in this technical note is manufactured by vendors independent of Strategy. Strategy makes no warranty, express, implied or otherwise, regarding this product, including its performance or reliability. 
 
 


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Knowledge Article

Published:

March 29, 2017

Last Updated:

March 29, 2017