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KB47139: "Invalid procedure call or argument" error message appears when scheduling a report to History List in MicroStrategy Developer 9.x and 10.x


Stefan Zepeda

Salesforce Solutions Architect • Strategy


"Invalid procedure call or argument" error message appears when scheduling a report to History List in MicroStrategy Developer 9.x and 10.x

SYMPTOM:
Whenever a user tries to schedule a report to deliver to History List  from Strategy Developer 9.x and 10.x they receive the following error.

ka02R000000kbqOQAQ_0EM4400000029PL.png

 

ka02R000000kbqOQAQ_0EM4400000029PR.png


Invalid procedure call or argument

 
In addition to this, within the same metadata if a user tries to create a new subscription within Administration -> Configuration Managers -> Subscriptions they will receive the error message below.

ka02R000000kbqOQAQ_0EM4400000029PO.png


Object with ID 'XXX' and type 51 (Schedule Trigger) is not found in the metadata.  It may have been deleted.

 
CAUSE:
The second error better explains the issue at hand here.  The issue is due to a particular schedule object missing from the metadata while it still has a reference to the project.
 
ACTION:
Within a separate environment, perform a search for the object ID presented in the second error message mentioned above.  The search can be performed using Strategy Desktop 9.3.0 within Administration -> Configuration Managers -> Schedules by doing a "search by ID".  If the schedule object is returned and exists within a different environment, Strategy Object Manager can then be used to migrate the object back into the problematic environment so it exists successfully.
 
If the reference is not found in another environment, contact Strategy Technical Support for assistance in finding the problematic reference.


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Knowledge Article

Published:

June 8, 2017

Last Updated:

June 8, 2017