SYMPTOM:
With the Intelligence Server running on UNIX/Linux, the following error message appears in Strategy DB Query Tool or Strategy Developer/Desktop when attempting to connect to a Microsoft Excel data source.
Sample Code/Error
Error type: Odbc error. Odbc operation attempted: SQLDriverConnect. The Microsoft Jet database engine cannot open the file '(unknown)'. It is alread opened exclusively by another user, or you need permission to view its data.
Additionally, the intelligence Server DSN uses the SequeLink driver and the Excel file is located on a network drive. Windows DSN connects successfully.
Note: The Microsoft Excel file requires preparation and the DSN must be configured as per the notes in Appendix A notes of the Installation and Configuration Guide and the following Strategy Knowledge Base Technical Note:
KB32624 - How to configure Strategy Intelligence Server Universal running on UNIX/Linux operating systems to connect to Microsoft Access and Excel data sources.
CAUSE:
The Excel file cannot be accessed by the Windows machine hosting the SequeLink ODBC Socket Server and Agent. One possibility is that the SequeLink ODBC Socket Server and Agent are running under the "local system account".
ACTION:
On the Windows machine hosting the SequeLink ODBC Socket Server and Agent: