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KB47505: "The connection failed..." error message is encountered when connecting from Developer to an Intelligence Server running on UNIX/Linux when the IPTables firewall is enabled on the Intelligence Server machine in MicroStrategy 9.4.x - 10.x


Stefan Zepeda

Salesforce Solutions Architect • Strategy


This technical note outlines an issue that prevents Developer from connecting to a Unix Intelligence Server.

SYMPTOM:
The following error message is encountered when connecting from Developer to an Intelligence Server running on UNIX/Linux when the IPTables firewall is enabled on the Intelligence Server machine in Strategy 9.x - 10.x.
 

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The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit

 
 
When the error is encountered, the Intelligence Server state is "running" (which can be verified by using the ‘mstrctl –s IntelligenceServer gs’  command from the <Strategy HOME>/bin directory using command prompt/terminal, as shown below).
 

ka02R000000kc3NQAQ_0EM440000002CIz.png

 
 
CAUSE:
One possible cause for this issue is the IPTables firewall being enabled on the Intelligence Server machine which blocks any network packets that cross the networking interface between the Intellignece Server and the client machine.
 
ACTION:
Users should check with the Network Administrator to make sure that the IPTables Firewall is configured properly so that the communication between the Intelligence Server and client machine is not blocked. Disabling it should resolve the issue.
 


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Knowledge Article

Published:

May 31, 2017

Last Updated:

May 31, 2017