EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB47650: "Maximum number of result rows retrieved per report was exceeded" error message returned when executing a data mart report in MicroStrategy Developer


Stefan Zepeda

Salesforce Solutions Architect • Strategy


'Maximum number of result rows retrieved per report was exceeded.'thrown when running a data mart report after setting the maximum number of result rows for data marts to infinite (-1) or a very large number (999999999)

SYMPTOM:
 
When running a data mart report after setting the maximum number of result rows for data marts to infinite (-1) or a very large number (999999999), the following error is thrown:
 

ka02R000000kXzFQAU_0EM440000002CIY.png

 
 


Error: Maximum number of result rows retrieved per report was exceeded.[Maximum number of result rows retrieved per report was exceeded. XXX, it is set for "YYY"]Error in Process method of Component: QueryEngineServer

 
CAUSE:
 
In each new data mart report, there is a setting for maximum number of result rows that functionally ignores the project-level setting.
 
ACTION:
 
Upon configuring the data mart in the Advanced tab, increase the "Maximum number of rows (Analytical Engine)" setting to 999999999 (functional limit for data marts).
 

ka02R000000kXzFQAU_0EM440000002CIU.png

 
 
 


Comment

0 comments

Details

Knowledge Article

Published:

June 12, 2017

Last Updated:

June 12, 2017