EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB47922: Selector with many values on panel stack does not allow scrolling when accessed from Android mobile device 9.4.1, but scrolling does work in Web and iOS.


Community Admin

• Strategy


KB47922: Selector with many values on panel stack does not allow scrolling when accessed from Android mobile device 9.4.1, but scrolling does work in Web and iOS.

SYMPTOM:
 
Consider the scenario below, as reproduced in Strategy Tutorial 9.4.1:
 
1)  In Strategy Tutorial 9.4.1, create a new report with a single attribute that has a lot of values, like "Customer".  Save and close the report.
 
2)  Create a new document with the report in step (1) as a dataset.  Create a small panel stack in the Detail Header section.
 
3)  Create a List Box selector (Vertical) on the panel stack that chooses from the elements of the Customer attribute.
 
4)  In the Panel Stack > Properties and Formatting > Layout make sure the "Content Overflow" is set to scroll.
 
5)  In the selector > Properties and Formatting > Layout > Size > make sure that the "Height" is set to "Fit to contents" (this may need to be set in Desktop, not Web).
 
6)  Run the report in Web and note that the selector has a scroll bar that allows scrolling down through the values.
 
7)  On the Mobile Admin page, create a mobile config for iPad.  Test document from iPad and see that the scrolling works there as well.
 
8)  Create a mobile configuration for Android Phone and test from mobile device.  Note that on the device scrolling does not work.
CAUSE:
 
This is a known issue with Strategy Mobile 9.4.1 running on an Android device.
 
ACTION:
 
Contact Strategy Technical Support for an update on this issue.
 


Comment

0 comments

Details

Knowledge Article

Published:

June 1, 2017

Last Updated:

June 1, 2017