EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB486740: Users do not have access to content when creating history list subscription in MicroStrategy Workstation


Zhanghao Zhan

Cloud Support Engineer II • MicroStrategy


This article documents an issue in MicroStrategy Workstation which returns an error when a user tries creating a new subscription.

Symptom:

A user cannot create a new subscription for history list in Strategy Workstation:

ka0PW0000001RxRYAU_0EMPW000005J8Op.png

 


User 'xxxxx’ does not have Read access to the ServerDef object 'xxxxxx' in Project Configuration with ID 'xxxxxxx'.) Intelligence Server Error Code: -2147214568 Library Server Error Code: ERR017 Ticket ID: xxxxxxxx.' 

 

Steps to Reproduce: 

1. Create a user and make sure the user has the privilege “Use Distribution Services" and  "Web Subscribe to History List".
2. Go to Strategy Workstation and login as the new user.
3. Click the button to create a new subscription and in the Type list choose history list. The following error message will appear:


You don't have access to content.
User 'xxxxx’ does not have Read access to the ServerDef object 'xxxxxx' in Project Configuration with ID 'xxxxxxx'.) Intelligence Server Error Code: -2147214568 Library Server Error Code: ERR017 Ticket ID: xxxxxxxx.' 

 

Cause: 


This issue occurs due to the fact that the users does not have Read permission to the Server definition object.

Action: 


1. Go to Strategy Developer and configure the Intelligence Server by right clicking the project source.
2. Navigate to Server Definition > General > Properties
3. Click on "Modify" and go to the security section.

ka0PW0000001RxRYAU_0EMPW000005J8Oq.png

4. Change the permission for the Everyone group to Monitoring;

ka0PW0000001RxRYAU_0EMPW000005J8Or.png

5. Log back in Strategy Workstation. The error should no longer appear. 
 


Comment

0 comments

Details

Knowledge Article

Published:

May 31, 2024

Last Updated:

May 31, 2024