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KB8192: 'More than one failed migration windows were found. This process cannot continue' error message appears when performing a data load in MicroStrategy Enterprise Manager 9.x


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• Strategy


This document explains how to resolve the error 'More than one failed migration windows were found. This process cannot continue.' when performing a data load in MicroStrategy Enterprise Manager 9.x

SYMPTOM
In Strategy Enterprise Manager, users see the following error message when attempting to run a data load:
 


'More than one failed migration windows were found. This process cannot continue.'

 
CAUSE
Due to inconsistencies during the data load or due to earlier failed custom time window loads , the last column of the EM_IS_LAST_UPDATE table, IS_STATUS, that indicates a successful or a failed load (1 or 0) has more than 2 rows with IS_STATUS=0. By design, the first row in the EM_IS_LAST_UPDATE (when sorted by IS_WIN_BEGIN or IS_PROC_BEGIN) table should have IS_STATUS=0. If any other row has an IS_STATUS = 0, the error message in the title appears.
 
ACTION
The users can update the IS_STATUS column of the EM_IS_LAST_UPDATE table wherever they see zero except the very first row that reads as shown below: 

ka04W00000147q5QAA_0EM440000002BuM.jpeg

 
 
Once the EM_IS_LAST_UPDATE table is updated, the users can run a Custom Time Window Load under the Data Load Options in the Strategy Enterprise Manager console, which encompasses the time period for which they have not been able to do the data load or have been missing data.
 
NOTE: If the users just update the EM_IS_LAST_UPDATE table without a Custom Time Window Load to follow, they can experience loss of data for the time period that begins with the timestamp in the IS_WIN_END column of the first updated IS_STATUS row of zero ending with the last such updated row.
 
 
Enterprise Manager warehouse modification:
WARNING:
Manually editing values in the Strategy Enterprise Manager warehouse incorrectly may cause serious, project-wide problems that may make your project unusable and/or the data load to fail. Since these are user-initiated changes, they are not covered by any Strategy warranty. Users are strongly encouraged to back up the Strategy Enterprise Manager warehouse prior to any alteration.
 
 
 
 
 
 


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Knowledge Article

Published:

March 30, 2017

Last Updated:

March 30, 2017