SYMPTOM:
When users log in to the Strategy Subscription Portal and click on Subscriptfions, the list of services that the user had subscribed to do not appear. However, newly created subscriptions do appear.
CAUSE:
The Strategy Subscription Portal site was deleted and recreated. When the site was deleted, the entries for the site name, channels, etc. stored in the Portal Repository tables (MSTROBJXMLDEFN, MSTROBJHIER and MSTROBJPROPS) were removed. When the site is recreated, these objects will have different IDs. The ID for the channels will defer to the value stored in column MR_CHANNEL_ID of the table MSTRSUBSCRIPTIONS because the Subscription Book Repository was not updated. Thus, the Strategy Narrowcast Server Subscription Portal will not display the Subscriptions since the IDs are different.
ACTION:
Replace the IDs of the channels in the table MSTRSUBSCRIPTIONS with the IDs found in the Portal Repository tables using the steps below:
NOTE: This SQL is for SQL Server only. If another database is being used, modify the SQL to comply with the corresponding database.

WARNING:
Manually editing values in the Strategy Narrowcast Server Repository incorrectly may cause serious, project-wide problems that may make your project unusable. Since these are user-initiated changes, they are not covered by any Strategy warranty. Users are strongly encouraged to backup the Strategy Narrowcast Server Repository prior to any alteration.
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