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KB26556: Security Filter Manager causes MicroStrategy Developer 10.0 - 10.4 Hotfix 1 to hang when using an SSL-enabled project source


Vanessa Munoz

Cloud Support Expert I • MicroStrategy


This technical note outlines a known issue that occurs when SSL has been enabled at the project source level, in MicroStrategy Developer.

SYMPTOM:
After logging into a project source with SSL enabled, user tries to open the Security Filter Manager, which is accessible from Administration menu > Projects > Security Filter Manager, Strategy Developer hangs and, when the project source time out value is reached, the following error appears:

ka02R000000kbPhQAI_0EM440000002TDt.png

 


Network: Please retry task due to network request timeout. If problem persists, contact your network administrator.

Additionally, the following error is recorded in the DSSErrors.log:
 

2017-06-27 10:53:42.728+01:00 [HOST:xxxx][PID:2748][THR:963151616][Network Classes][Error] SSL accept error : error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol

The Project Source has the "Enable SSL option" checked whereas "Verify Server Certificate" is unchecked:

ka02R000000kbPhQAI_0EM440000002TDy.png

The issue will not occur if SSL is not enabled for the project source.
CAUSE:
This is a known issue with Strategy Developer 10.0 - 10.4 HF1 and 10.5.
ACTION:
This issue has been addressed in Strategy Developer 10.4 HF2 and 10.6. Upgrade to those or newer versions to take advantage of this fix.
 


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Knowledge Article

Published:

June 29, 2017

Last Updated:

June 29, 2017