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KB439525: The results of a failed export may be cached when exporting dashboards or dossiers to PDF in MicroStrategy 10.6 and later


Frederick Kellerman

Cloud Support Expert I • MicroStrategy


This document discusses a known issue in MicroStrategy Secure Enterprise 10.6 and later which may occur when exporting dashboards or dossiers to PDF.

Starting with the release of Strategy ONE (March 2024), dossiers are also known as dashboards.
OVERVIEW
Users may notice that in some situations the results of a failed export to PDF of a dashboard or dossier are cached on the Intelligence Server as document caches in Strategy Secure Enterprise 10.6 or later. This may result in situations where the underlying cause of an error message has been resolved, but users still receive the error message when exporting a dashboard or dossier to PDF because these subsequent exports may hit the document cache where the error message is cached.
STEPS TO REPRODUCE​
The following steps illustrate a circumstance under which the issue can occur. Note that there may be other cases under which this behavior is seen.

  1. Configure PDF document caching for the project under Project Configuration->Caching->Creation. Check the box for PDF under Enable Document Output Caching In Selected Formats.
  2. Set the value for Sub-Process Execution Timeout (sec) for the Strategy PDF Exporter to be 1 so that dashboard/dossier exports to PDF will timeout. This setting is configured in Strategy Service Manager, Strategy PDF Exporter->Service Options->Export Engine Service Options. Restart the PDF Exporter after making this change.
  3. Export a dashboard/dossier to PDF. Note that even though the export fails a document cache in PDF format is created. The document cache can be viewed from Strategy Developer, Administration->System Monitors->Caches->Documents. When the export times out the following error message will be seen. 
    
    Page rendering timed out. Please contact your administrator to increase the timeout value in the configuration file, then restart Export Engine Service to try again.

  4. Revert the Sub-Process Execution Timeout (sec) setting back to it's original value so that PDF exports should no longer timeout. Restart the PDF Exporter service.
  5. Export the dashboard/dossier from step 3 to PDF again. Note that the the export still fails with the same error message and that the hit count for the document cache created in step 3 increases.

CAUSE
This behavior is a known issue when exporting dashboards/dossiers to PDF in Strategy 10.6-10.10. The Strategy Technology department is investigating the feasibility of implementing a fix to this issue in an upcoming release of Strategy. The internal reference number for this issue is DE86363.
ACTION
After the root cause of the original export error has been addressed (in this case raising the timeout setting discussed above) purge document caches for the dashboard/dossier in question. This will ensure that the document cache where the error message is stored is invalidated and can no longer be hit by subsequent exports. KB439525


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Knowledge Article

Published:

January 25, 2018

Last Updated:

March 21, 2024