Starting with the release of Strategy ONE (March 2024), dossiers are also known as dashboards.
OVERVIEW
Users may notice that in some situations the results of a failed export to PDF of a dashboard or dossier are cached on the Intelligence Server as document caches in Strategy Secure Enterprise 10.6 or later. This may result in situations where the underlying cause of an error message has been resolved, but users still receive the error message when exporting a dashboard or dossier to PDF because these subsequent exports may hit the document cache where the error message is cached.
STEPS TO REPRODUCE
The following steps illustrate a circumstance under which the issue can occur. Note that there may be other cases under which this behavior is seen.
Page rendering timed out. Please contact your administrator to increase the timeout value in the configuration file, then restart Export Engine Service to try again.
CAUSE
This behavior is a known issue when exporting dashboards/dossiers to PDF in Strategy 10.6-10.10. The Strategy Technology department is investigating the feasibility of implementing a fix to this issue in an upcoming release of Strategy. The internal reference number for this issue is DE86363.
ACTION
After the root cause of the original export error has been addressed (in this case raising the timeout setting discussed above) purge document caches for the dashboard/dossier in question. This will ensure that the document cache where the error message is stored is invalidated and can no longer be hit by subsequent exports. KB439525