EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB19911: "Load Document Data XML failed: Error #2032. Bootstrap Sequence has failed." error occurs while running a dashboard in MicroStrategy Web


Community Admin

• Strategy


Load Document Data XML failed: Error #2032. Bootstrap Sequence has failed.

SYMPTOM 

Users receive a bootstrap error message when running a dashboard in flash mode in Strategy Web. When analyzed with the Flash debugger (Ctrl+Alt+Shift+D), the following error appears.

ka04W00000148eKQAQ_0EM4400000028Ru.jpeg

Load Document Data XML failed: Error #2032. Bootstrap Sequence has failed.
Notice that the Definition XML was successfully loaded.
 
This issue can be analyzed better using Fiddler. Refer to the following Technical Note for more information on using Fiddler - KB17633: 'How to use Fiddler to retrieve data and definition XML from a Flash document in MicroStrategy Web 8.1.x., 9.x and 10.x
 

CAUSE 

Even when there are several causes for the #2032 bootstrap error, the most common cause for it is when the Data XML fails to load, as shown in the image below.
 

ka04W00000148eKQAQ_0EM4400000028Ry.jpeg

 
HTTP/1.1 500 Internal Server Error.
 
---
 
'errorMessage': '(System Error 0x80004005 (2147500037): --- unspecified error)',
'statusCode' :  500,
'taksErrorCode': -2147467259
This error occurs because of a timeout within the httpRuntime handler of the .NET framework ASP processor.
 
This error resembles the issue described in the following Technical Note:

  • KB16800: "Server Error in '/MicroStrategy' Application. Request timed out." error message appears when attempting to perform an operation in MicroStrategy Web 9.x for ASP.NET

 

ACTION

There are two timeout settings that affect Strategy Web. One is handled by IIS as described in tech note KB16800.
The other one is in the Strategy Web Admin page > Default Properties > Request Timeout (default is 40 seconds).
Increase the timeout to verify if the dashboard would execute correctly if it has enough time to load.
 


Comment

0 comments

Details

Knowledge Article

Published:

March 31, 2017

Last Updated:

March 31, 2017