EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB320120: Google Sankey Diagram Displays White Logo After Deploying from Visualization Gallery into MicroStrategy Visual Insight Dashboard


Community Admin

• Strategy


SYMPTOM:
The Google Sankey Diagram  from Strategy's Visualization Gallery is deployed in Strategy Web. After opening a new Strategy Visual Insight Dashboard in Strategy Web, the icon for the visualization in the gallery is blank.
It is possible to hover the mouse over the icon and see the name and descriptive information for the visualization, but the icon itself remains blank:

ka04W00000147v6QAA_0EM440000002GMA.jpeg

 
CAUSE:
This a known issue with the Html5ViPage.css file within Strategy's visualization plugin.
 
ACTION:
The CSS has been corrected in the latest version of the Google Sankey Diagram, download the latest version  of this visualization and replace the older version in Strategy Web to take advantage of this fix.
 
WORKAROUND:
This issue can be manually corrected if needed, by navigating to the CSS file within the visualization plugin:


GoogleSankey/style/Html5ViPage.css

 
Edit this file in any plain-text editor, and observe that the background-image property values inside the CSS file refer to absolute URLs for the icon files, which are invalid in most environments:

ka04W00000147v6QAA_0EM440000002GM9.jpeg

 
Replace the following part of each URL:


http://localhost:8081/Strategy/plugins/GoogleSankey/style/images/

with: 

../style/images/

 
These changes convert these absolute URLs into relative URLs that'll work regardless of the real environment URL.
 
Save all changes, restart Strategy Web and clear browser caches for the changes to register. These changes point the image references to the icon files within the plugin using a relative URL.
ADDITIONAL INFORMATION:
The Strategy SDK allows you to customize several Strategy products and extend and integrate the Strategy business intelligence functionality into other applications. However, before changing the way Strategy products look or behave, it is helpful to understand how the application is built. For more information regarding the Strategy products or the process of customizing Strategy products, please refer to Strategy Developer Zone (https://developer.Strategy.com).
To access the Strategy Developer Zone, you must have access to the Strategy Knowledge Base, you must have purchased the Strategy SDK, and you must be current on your Strategy maintenance agreement. If you are a US-based business and believe that you satisfy all three of these conditions but you do not have access to the Strategy Developer Zone, please contact Strategy Technical Support at support@Strategy.com or at (703) 848-8700. If you are an international business, please contact Strategy Technical Support at the appropriate email address or phone number found at https://www.Strategy.com/us/services/support/contact.
CUSTOMIZATION WARNING:
This customization is provided as a convenience to Strategy users and is only directly applicable to the version stated. While this code may apply to other releases directly, Strategy Technical Support makes no guarantees that the code provided will apply to any future or previous builds. In the event of a code change in future builds, Strategy Technical Support makes no guarantee that an updated version of this particular customization will be provided. In the event of a code change in future builds, Strategy may not be able to provide additional code on this matter even though this customization is provided at this time for this specific build. For enhancements to this customization or to incorporate similar functionality into other versions, contact your Account Executive to inquire about Strategy Consulting assistance.


Comment

0 comments

Details

Knowledge Article

Published:

March 30, 2017

Last Updated:

March 30, 2017