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KB38914: "The object shown in the following hierarchy no longer exists in schema: -Link-TableObject is not found in DFCSchema during DFC conversion.Message from GetErrorInfo : Incorrect login/password.." error message in MicroStrategy 2021.


Stefan Zepeda

Salesforce Solutions Architect • Strategy


This article explains an error thrown when updating schema in MicroStrategy 2021.

SYMPTOM:
When the user updates schema in Strategy Developer (3-tier), the following error occurs:


Error(s) occurred while loading schema: DSSSQLEngine: Schema loading error: Population Exception: The object shown in the following hierarchy no longer exists in schema: -Link-TableObject is not found in DFCSchema during DFC conversion.
Message from GetErrorInfo : Incorrect login/password..

 
This error only happens in 3-tier. In 2-tier, the update schema works without any error.
 
CAUSE:
One possible cause is that one or more table objects are moved to regular folder from "Temporary Tables to Delete" folder. The result of this behavior is done by an older version of ScanMD which is no longer supported by Strategy Technical Support. To identify the problem, the user can browse all tables and if a table is moved by ScanMD, the table name becomes +, for example,
 

ka0PW0000000wX3YAI_0EM440000002DPA.jpeg

 
ACTION:
Using a version other than the latest version of ScanMD is not supported.  Refer to the following technical note for the latest ScanMD release:
 
KB483179  - Using ScanMD to fix known logical metadata inconsistencies in the Strategy Product Suite 2021 and later
 
WORKAROUND:
To resolve the issue, please follow steps below:

  1. Launch Search editor and locate all table objects.
  2. Remove any table object with the type of +.
  3. Update schema.

If the issue persists, please contact Strategy Technical Support for further assistance.
 
 


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Knowledge Article

Published:

April 12, 2017

Last Updated:

February 26, 2024