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KB426590: “Could not find a Google Analytics account for your account. ” error shows when trying to import Google Analytics data in MicroStrategy Web 10.x.


Monica Gallegos Salazar

Principal Product Specialist • MicroStrategy


“Could not find a Google Analytics account for your account. Please sign in with a different account.” error shows when trying to import Google Analytics data and a loop is created in MicroStrategy Web 10.x.

SUMMARY:
This issue has been classified as a defect by Strategy.  The impact is from the Strategy Web 10.x product when trying to use the Google Analytics connector. A solution/code fix for this issue is not available in current releases and has not been scoped for a future Strategy release.
SYMPTOM:
After following the steps in article KB263684 to configure the Google Analytics connector, the following error shows:
 

ka04W000001IqS2QAK_0EM440000002TSo.png

 


Could not find a Google Analytics account for your account. Please sign in with a different account.

 
STEPS TO REPRODUCE:

  1. Follow the steps in article KB263684: How to import data from Google Analytics in MicroStrategy Web 10.x to configure the Google Analytics connector.
  2. Open Strategy Web using the HTTPS protocol.
  3. Select “Add External Data” and select Google Analytics.
  4. A new window will be opened to enter the Google credentials:
ka04W000001IqS2QAK_0EM440000002TSt.png
  1. After this, the following warning will show:


 

ka04W000001IqS2QAK_0EM440000002TSy.png

 

  1. Click Allow, and you will be redirected to the Strategy Web page, in which the error above will show and a you will be redirected to step 4 creating a loop.


 
CAUSE:
A possible cause of the issue is that Internet Explorer is used when doing the configuration.
ACTION:
Use a different browser to configure the Google Analytics account, once this is done, the Google Analytics account will be available to be used in Internet Explorer. KB26590 KB426590


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Knowledge Article

Published:

June 30, 2017

Last Updated:

December 31, 2018