EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

​​​​​​​KB442262: With Data Engine Version=11, incorrect data is displayed due to wrong application of a filter


Community Admin

• Strategy


In MicroStrategy, with Data Engine set to 11, user may have missing data due to a filter being applied incorrectly on a metric.

Symptoms

  • Missing data (missing rows, blank cells)
  • Attribute filter applied on metric

 

Glossary

  • What is CSI?
  • Absolute filtering

 

Steps to Reproduce


The following example uses Strategy Tutorial attributes and metrics. In a document composed of two metrics and attributes from 2 separate reports (refer to them as R1 and R2), one metric M06 is missing data.
The missing data is due to an absolute filter for Region on M06 conflicting with other filters:

  • report level filter on Region from R1
  • view filter on Region from R2


In other words, the Region level filter on the metric leads to it being filtered again after the other filters have already been applied in calculation.
M06 metric definition:

ka04W00000148m4QAA_0EM2R000000hFRb.jpeg
ka04W00000148m4QAA_0EM2R000000hFRH.jpeg

R1 report filter, attributes, metrics:

ka04W00000148m4QAA_0EM2R000000hFiN.jpeg
ka04W00000148m4QAA_0EM2R000000hFih.jpeg

R2 view filter, attributes, metrics:

ka04W00000148m4QAA_0EM2R000000hFiS.jpeg
ka04W00000148m4QAA_0EM2R000000hFim.jpeg

Grid results & query details (CSI):
Before

ka04W00000148m4QAA_0EM2R000000hF1Y.jpeg

After

ka04W00000148m4QAA_0EM2R000000hF1d.jpeg

 
 Current CSI


 select      [Call Center]@[CALL_CTR_ID],
             [Call Center]@[CENTER_NAME],
             [Quarter]@[QUARTER_ID],
             [Quarter]@[QUARTER_DESC],
             [Region]@[REGION_ID],
             [Region]@[REGION_NAME],
             max([Revenue])@{[Quarter],[Region]} as [M06_MaxRev_Q*R*_AFB]
 from        Ex0_tempcube17
 where       ([Region]@[REGION_ID] in (Set of [Region]@[REGION_ID] where [Call  Center]@[CALL_CTR_ID] in (7, 11) )
             and [Quarter]@[QUARTER_ID] in (Set of [Quarter]@[QUARTER_ID] where [Month]@[MONTH_ID] in (200504,                 200505, 200507, 200508, 200606, 200609) ))
 display having    ([Call Center]@[CALL_CTR_ID] in (7, 11)
                           and [Month]@[MONTH_ID] in (200504, 200505, 200507, 200508, 200606, 200609))
 to          Ex0_tempcube18


 
 New CSI

 select [Call Center]@[CALL_CTR_ID],
        [Call Center]@[CENTER_NAME],
        [Quarter]@[QUARTER_ID],
        [Quarter]@[QUARTER_DESC],
        [Region]@[REGION_ID],
        [Region]@[REGION_NAME], max([Revenue])@{[Quarter],[Region]} as [M06_MaxRev_Q*R*_AFB] 
 from   Ex0_tempcube11 
 (filtering step removed as it's already done at the report level)
 to     Ex0_tempcube12


Note: Screenshots taken in Strategy Web.
 

Cause


This is a known defect in Strategy 11.0 with Data Engine set to 11. When an attribute filter is applied, incorrect logic sometimes reapplies the filter again after the metric has already been calculated, resulting in missing data. 

  • In the case above, various filters on Region are applied more than once during calculation.


This is NOT applicable when Data Engine is set to 10, therefore user may have missing data when changing the Data Engine setting from 10 to 11 or see previously not shown data when upgrading from Strategy 11.0.
 

Solution

  • Upgrade to Strategy 2019 or above.
  • Set Data Engine setting to 11.
    • The project level setting Data Engine can only be enabled through Workstation. For more details on enabling the setting, see Change Data Engine Version.


In the new fix, filters are only applied once when calculating metrics, and so do not create cases of missing data.


Comment

0 comments

Details

Knowledge Article

Published:

November 19, 2018

Last Updated:

June 7, 2019