EducationSoftwareStrategy.com
StrategyCommunity

Knowledge Base

Product

Community

Knowledge Base

TopicsBrowse ArticlesDeveloper Zone

Product

Download SoftwareProduct DocumentationSecurity Hub

Education

Tutorial VideosSolution GalleryEducation courses

Community

GuidelinesGrandmastersEvents
x_social-icon_white.svglinkedin_social-icon_white.svg
Strategy logoCommunity

© Strategy Inc. All Rights Reserved.

LegalTerms of UsePrivacy Policy
  1. Home
  2. Topics

KB483391: How to troubleshoot the error “()” appearing in the MicroStrategy Web or Library interface?


Community Admin

• Strategy


This knowledge base article describes the common known occurrences of the '()' error and indicates workarounds or the release in which the issue will be addressed.

Starting with the release of Strategy ONE (March 2024), dossiers are also known as dashboards.
Strategy Web or Strategy Library may display an error message just containing empty parentheses.

ka0PW0000001JiyYAE_0EM2R000000hO3O.jpeg

These errors usually indicate that error handling is not passing the underlying error to the front-end. To locate the root cause of the error, you must cross reference with the server side Strategy logs, which are the Web or Library log and Strategy Intelligence Server DSSErrors.log.  
It's recommended to collect the following log files to provide to Technical Support:

  • Fiddler trace with TLS/SSL encryption enabled. See KB20064: How to install and use Fiddler for MicroStrategy Web troubleshooting and KB20047: How to use fiddler when using HTTPS secure TCP connection with MicroStrategy We.
  • Web logs, located at WEB_DEPLOYEMNT/WEB-INF/log.
  • DSSError logs from the Intelligence server machine. For steps, see KB11140: What is the DSSErrors.log, how does it work and where is it located for MicroStrategy Intelligence Server 9.x and 10.x?
  • Library logs, see Configure Logging for Windows Deployment  or Configure Logging for Linux Deployment.


In a clustered environment, provide logs from all nodes or ensure the log is collected from the node that hosts the session. Additionally, ensure that the logs cover the time or reproduction.
The following sections describe known occurrences of the () error and indicate workarounds or provide the release in which the issue has been addressed.
Actions that cause () error:

  • Submitting transactions in Transaction Services.
  • Using the Save As button for a dossier on top of an existing dossier.
  • Accessing MicroStrategy Library.
  • Using search box filtering in dossiers or documents.
  • Opening a document or dossier in Web.

Submitting transactions in Transaction Services

Symptom


When submitting a created transaction with the Allow submission without modification property enabled, the () error appears in Web.
In the DSSErrors.log, it may say:

[HOST:esld22799][SERVER:CastorServer][PID:34507][THR:140388196919040][Kernel][Error] XMLRebuildDocument: PreRebuildDocument failed with error -2147467259, return original Message ID 6F2F964D11E788A308EA0080EF855B5D

Steps to Reproduce

  • Edit the document using Strategy Transaction Services.
  • Enable Allow submission without modification in the Configure Transaction properties panel.
ka0PW0000001JiyYAE_0EM2R000000hTDq.jpeg
  • Run the document in presentation mode and Submit.

Cause


This is a known defect in versions of Strategy prior to 10.9.
 

Solution


This defect is addressed and fixed in Strategy 10.9. Upgrade to Strategy 10.9 or later to take advantage of the fix.
 

Workaround


In the short-term, avoid using the Allow submission without modification property. Disabling this property can resolve the issue.
 

Using the Save As button for a dossier on top of an existing dossier

Symptom


Clicking the Save As button on a dossier causes the () error to appear.

ka0PW0000001JiyYAE_0EM2R000000hTDl.jpeg

Steps to Reproduce

  1. In Web, open an existing dossier.
  2. From the File menu, select Save As.
  3. When the dialog box says "Do you want to replace the existing object?" select Yes. The error appears.

Cause


This is a known defect in Strategy 2019.
 

Solution


This defect is addressed and fixed in Strategy 2019 Update 1. Upgrade to Strategy Update 1 or later to take advantage of the fix.
If this error appeared in Strategy 10.1, view KB275989: “Error in save as” error received when using ‘Save As’ in MicroStrategy Web 10.1.
 

Accessing Strategy Library

Symptom


When logging into Strategy Library or adding a dossier to your Library, the error Application Error () appears.

ka0PW0000001JiyYAE_0EM2R000000hO63.jpeg

In DSSErrors.log we can see the following corresponding entry:

[HOST:][SERVER:CastorServer][PID:3892][THR:9176][Kernel][Error][UID:0][SID:0][OID:0] DSSServerDispatcher. error dispatching request = -1. err = 0x800436F8. error message = MsiChannel read failed.

In Library log:
[code=ERR001, iServerErrorCode=-2147467259, message=(), httpStatusCode=500, ticketId=…]

Cause


This error message appears when a project is not configured to allow users to create a profile folder. This issue is specific to Strategy 11.0 and 2019.
 

Solution


This defect is addressed and fixed in Strategy 2019 Update 1 and Strategy 2020. Upgrade to Strategy Update 1 or later to take advantage of the fix.
 

Workaround

  • Log in to Strategy Developer as an Administrator.
  • Go to Project Configuration > Project Definition > User Profiles.
  • Select the Create user profiles at login checkbox.
ka0PW0000001JiyYAE_0EM2R000000hO71.jpeg
  • Click OK.

Using search box filtering in dossiers or documents

Symptom


When entering a name of an object into a filter search box, the () error appears.

ka0PW0000001JiyYAE_0EM2R000000hUrc.jpeg

Steps to Reproduce

  1. In Web, create a dossier.
  2. Drag an attribute to the filter panel.
  3. Change the filter type from default to Search Box.
  4. Enter the name of an attribute. The error appears.

Cause


This is a known defect in Strategy 10.11.
 

Solution


This defect is addressed and fixed in Strategy 11.0 and Strategy 2019. Upgrade to Strategy 11.0 or later to take advantage of the fix.
If this error appeared in versions prior to Strategy 10.11, it's likely due to a corrupt attribute beign used for the Search Box. Try to recreate the attribute using Command Manger. For instructions, see Alter attribute statement.
 

Opening a document or dossier in Web

Symptoms


When running a document or dossier in Web, the User request is complete () error appears.

ka0PW0000001JiyYAE_0EM2R000000hO7f.jpeg

Cause


This may be a result of a corrupt object in the document or dossier. It is possible the object became corrupt during an upgrade or migration between different environments. 
 

Solution


To determine the corrupt object, check the object ID that is present in the DSSErrors.log and the timestamp of the issue reproduction. After, recreate the object.
 


Comment

0 comments

Details

Knowledge Article

Published:

June 24, 2019

Last Updated:

March 21, 2024