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KB47939: Users with a Number and Date Format custom language set with Command Manager see an error 'The connection failed. Possible causes are a) Server is not running [...]' when logging into MicroStrategy Web


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• Strategy


Users having a custom language Number and Date Format set with Command Manager see the error message : "Error in login. MicroStrategy Intelligence Server error: The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit" when logging into MicroStrategy Web 9.4.1.

SYMPTOM:
Users having a custom language Number and Date Format set via Command Manager see the following error message:

ka04W00000148IjQAI_0EM440000002621.jpeg


Error in login

Strategy Intelligence Server error: The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit. 
when logging into Strategy Web 9.x.

 
 
At the same time the DSSErrors.log shows entries similar to:

MSINetStream::readBinary() error - 1049609 is not a valid locale id

 
and the MSTRWeb.log contains errors like the one below:

<record>



  <package>com.Strategy.webapi</package>

  <level>SEVERE</level>

  <miliseconds>1407179984202</miliseconds>

  <timestamp>dd/mm/yyyy xx:xx:xx:xxx</timestamp>

  <thread>1</thread>

  <class>MSIMsgBuf</class>

  <method>ReadFromChannel</method>

  <message>MsiNetStreamI : Read error. (com.Strategy.webapi.MSTRWebAPIException)</message>

  ...

</record>

<record>

  <package>com.Strategy.webapi</package>

  <level>SEVERE</level>

  <miliseconds>1407179984202</miliseconds>

  <timestamp>dd/mm/yyyy xx:xx:xx:xxx</timestamp>

  <thread>1</thread>

  <class>CDSSXMLCommand</class>

  <method>ReadResponse</method>

  <message>The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c)  Network problem, or d) Server reached maximum connection limit. (com.Strategy.webapi.MSTRWebAPIException)</message>

...  

</record>

 
 
STEPS TO REPRODUCE:
 

  1. Create a new custom Metadata language "New English US" in Strategy Developer. For more information how to add a custom language please refer to product manual Strategy Supplemental Reference for System Administration > Chapter > CREATING A MULTILINGUAL ENVIRONMENT: INTERNALIZATION > Adding or removing a language in the system or to KB35222: How to create a new project language when Internationalization is enabled in Microstrategy Desktop 9.x
  2. Create a Web user and alter the Number Date Format in Strategy Command Manager to the new language e.g.


ALTER LANGUAGE FOR NUMBERDATE AT USER LEVEL FOR USER "new user" USE LANGUAGE "New English US";

  1. Go to Strategy Web and try to login. The error will occur.


​
CAUSE:
This is a known issue for custom languages in Strategy Web 9.4.1.
ACTION:
This issue has been addressed in Strategy 10.x. Upgrade to take advantage of the fix.
WORKAROUND:
Set the Number Date Format to the language the custom language is based on or any other supported language.
 
LEARN MORE ABOUT:
Please review the following article describing similar error messages in Strategy:

  • KB13082: ‘The connection failed. Possible causes are a) Server is not running, b) Server is loading project, c) Network problem, or d) Server reached maximum connection limit’ error is seen every 5 minutes in the Web Errors log in MicroStrategy Web

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Knowledge Article

Published:

May 1, 2017

Last Updated:

May 1, 2017