Strategy Library fully supports Kerberos authentication using Tomcat on Windows and Linux.
In Strategy ONE (June 2024), Tomcat is upgraded to version 10+. With previous configuration settings, an application error may occur when trying to log into Library via Kerberos authentication with the previous configuration.

Before attempting to resolve this situation, make sure the following prerequisites are met:
com.sun.security.jgss.krb5.accept {
com.sun.security.auth.module.Krb5LoginModule required
principal="HTTP/ASMachineName@DOMAIN_REALM"
useKeyTab=true
doNotPrompt=true
storeKey=true
debug=true;
};
com.Strategy.web {
com.sun.security.auth.module.Krb5LoginModule required
principal="HTTP/ASMachineName@DOMAIN_REALM"
useKeyTab=true
doNotPrompt=true
storeKey=true
debug=true;
};